OLPC updates bugs / solutions

icon1 flick harrison | icon4 Aug 28, 2008| icon3

So, for those of you using the XO Laptop (the One Laptop Per Child Project), this might help you update cleanly.

I wanted to upgrade to build 711, the latest stable release, but I didn't want all the kiddie / programming activities that come with the activity packs. I had some problems installing activities one at a time, and finally made Web 86 work after installing Firefox and Browse, both of which failed to start and seemed to prevent me from installing Web at first.

I updated the build using the simple online instructions. Then I downloaded all the activity .xo files using downthemall and put them on a USB key. Then, in the Journal, I clicked on them one at a time to install. I tried to choose Firefox, Browse, Terminal, Chat, Playgo, Newsreader, Record, Chat, and Write. (Hello! Can we have an Abiword install, without Write, PLEASE!)

After installing Firefox-4 and Browse-95, I saw that each one started up, flashed their icons on the Home View and then died. I suppose they are incompatible with build 711 or whatever.

I tried to install Web-86, which is the Activity that comes with the current G1G1 activity pack. It did nothing; in the Journal, it wouldn't "resume." It would simply open the full-page Journal article about itself when I clicked it, and the Resume button did nothing.

So - clever me - I restarted by holding the O on the game pad, to reboot in build 653. Tried both applications there - no luck. It was surprising, however, that they were still present in the old build - along with all my old Activities.

So I used terminal to navigate to root -> home/olpc/Activities and rm'ed both Firefox.Activity and Browse.Activity or whatever it was called. Then I restarted back into 711 and both offending progs were missing from the Activities bar. Awesome! Then I used journal to find Web-86 on my USB key, clicked it - and it installed!

Now it works fine!

PS - I have no idea if booting into the old OS helped anything, but it was interesting to see new-build Activities in the old build toolbar, but NOT vice versa. Anyone know why that happens?

%d bloggers like this: